SLA permissions do not work with project roles
This page is about Time to SLA for Jira On-Prem.
Problem
The Time to SLA top menu permissions, such as SLA Report, SLA Configuration, etc., do not work when they are set to project roles. Users cannot see SLA configuration pages even though they have selected roles in some projects.
Diagnosis
When you permit a project role for a top menu, TTS checks only global members of those roles because it is not feasible to check a role for each project in the system.
Note: This limitation applies only to Top Menu Permissions. All other permissions perform project-level project role permission controls since they are issue-based permissions.
Solution
We strongly recommend using groups to manage top menu permissions. If you would like to use project roles for Top Menu permissions, you can add a user as a global member of those roles.