I cannot use the Time to SLA field to search or order

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Time to SLA Cloud features – Review Cloud features and understand key differences between DC and Cloud.
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I cannot use the Time to SLA field to search or order

This page is about Time to SLA for Jira Data Center.

Problem

  • I cannot use the Time to SLA field while searching for issues.

  • I cannot order issues according to their Time to SLA values in the issue navigator.

  • I get the error "Field 'Time to SLA' does not exist or you do not have permission to view it." while upgrading TTS v7.

Causes

Time to SLA displays the remaining time on SLAs, which changes constantly. When you search with the Time to SLA field, Jira obtains values of Time to SLA from an underlying indexing mechanism, which may hold outdated values and thus generates wrong results.

Searching and ordering with the Time to SLA field is not possible in order to prevent incorrect results due to these shortcomings.

Possible workarounds

You can use TTS JQL functions and SLA Search 3.0 JQL Functionalities to search with the remaining time or the overdue time on SLAs.

It is not possible to order issues by their remaining time. Instead, you can use the SLA Dates custom field to order issues by their first SLA target date.

We are working on finding a better and consistent way to order your SLAs with Time to SLA field. The biggest drawback here is that the remaining time constantly changes. We want to provide a solution capable of handling this behavior whilst being lightweight enough to not disrupt your Jira operations.

Need support? Create a request with our support team.

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