Issue comment is not visible to the admin

Symptoms

In some cases (including after a deployment with CMJ) an issue comment might not be visible to the administrator.

Cause

The comment is restricted to a group/role that the admin doesn’t belong to, or the ‘comment visibility' Jira setting is set to ‘project roles only’.

Troubleshooting

To check the permissions please search the JIRAACTION table for the given issue:

select * from JIRAACTION where issueid = <<issue id>>;

Then, if it is restricted, make sure that the admin belongs to that group/role.

 

To check the ‘comment visibility’ setting, go to JIRA Settings > System > General Configuration for "Comment visibility" and see if it is "Groups & Project Roles" or "Project Roles only".

Resolution

Add the admin to the restricted group/role in Jira, or remove the comment visibility restriction in the database:

update JIRAACTION set actionlevel = null where id = <<id of the comment>>;