How to stop a long running snapshot in Configuration Manager for Jira
Problem Statement
While creating a snapshot of a project with several issues, if the process is interrupted and when an attempt to take another snapshot is made, the below error is thrown:
Error MessageÂ
Job with name 'com.test.jira.rollout.snapshot' has already been scheduled. (This message is an example)
Log EntriesÂ
ERROR user1234 xxxxxxxxx xxxxxxxxxxx 10.0.1.1,10.0.1.2,10.0.1.3 /rest/configuration-manager/1.0/snapshots/progress/4 [c.b.j.r.impl.rest.AbstractResource] com.test.jira.rollout.jobs.JobAlreadyScheduledException: Job with name 'com.test.jira.rollout.snapshot' has already been scheduled java.util.concurrent.ExecutionException: com.test.jira.rollout.jobs.JobAlreadyScheduledException: Job with name 'com.test.jira.rollout.snapshot' has already been scheduled
Environment
Application | Jira |
---|---|
Host | Datacenter |
Cause
CMJ allows for only one snapshot to be created at a time. This means that before you attempt another one, you should wait for the current one to complete.
Solution
To create a new snapshot:
- When an operation is running in the background, wait for the previously started operation to be completed. You can monitor this in the CMJ's Audit log for a message that suggests the snapshot is created. Please refer to Audit Logging for more details.
To stop the process of snapshot creation:
- Rarely can the operation get stuck because of an unexpected issue with the platform. To stop the process anyway, the solution is to restart JIRA and create a new snapshot.