Timeout or proxy error when deploying snapshot

Symptoms:

Deploying a snapshot results in one of the following errors:

  • Unknown: This site is currently undergoing maintenance. We apologize for the inconvenience. Proxy error.
  • Unknown: 504 Gateway Timeout
  • Request terminated: The current operation was terminated unexpectedly.

Often these errors come with no visible error in the Jira logs reported.


Cause:

These kind of errors usually indicate a client side or a network issue, i.e. something is terminating the request before it reaches the server. Firewall, proxy and browser timeouts are a common reason for such errors.

Note: On the initial step of the deployment wizard CMJ performs a long running HTTP request that can take up to several minutes while the target's configuration is being analyzed and compared to the snapshot. 

Resolution:

Option 1 - use the 'Path to snapshot file' feature:

You can either upload a snapshot file or select a path to a snapshot on current Jira's file system. This way, you can copy large snapshots directly to a location on the target Jira's file system, so you don't need to upload them from the browser. These are two alternative approaches to load a snapshot file.


Option 2:

The following actions could aid in the problem resolution:

  • If there is a proxy/firewall between the client machine and the destination server, increasing the timeout will keep longer running operations from terminating
  • Generating and analyzing a .HAR file of the network traffic from the time of the error helps identify request timeouts
  • Working together with a network administrator can help analyze the network infrastructure


Atlassian guide for troubleshooting network and connectivity issues:

See:

https://confluence.atlassian.com/kb/network-and-connectivity-troubleshooting-guide-720405335.html