"Unknown error! Please contact your administrator" message in the Salesforce Package (Server version)
Summary
After applying the API access token on the Salesforce package, an "Unknown error! Please contact your administrator" message appears even though the Connection seems to be successfully established:
Environment
Jira server
Connector for Salesforce & Jira (server) any version
Diagnostics Steps
You can use the following Apex code to check the connectivity from Salesforce to Jira:
Http http = new Http();
HttpRequest req = new HttpRequest();
req.setEndpoint('<JIRA URL>');
req.setMethod('GET');
HttpResponse response = http.send(req);
System.debug('STATUS: ' + response.getStatusCode());
System.debug('BODY: ' + response.getBody());
 Replace <JIRA URL>
with your Jira's base URL.
You can run the code by going to Salesforce > Developer Console > Debug > Execute Anonymous Window. Once you hit execute you'll be directed to the results.
Cause
This is usually caused by a connectivity issue between the Salesforce site and your Jira server instance.
Something might be blocking the connection (e.g. firewall, proxy, security software, or even redirections configured on Jira like SSO).
Here is an example of a proxy connectivity issue:
Workaround
This will require the integration user to bypass the proxy authentication should there be one
Update the Jira base URL to a non-SSO URL (this URL must be available to Salesforce Cloud)
Access the Jira non-SSO URL using an internal-user
Authorize the connection in JIRA
Generate the API token (by clicking on the three dots next to the connection) and copy it. Then paste the API token in installed packages → Salesforce and Jira Server Connector
Once authenticated on the package, go back to Jira and update the base URL again to the SSO-URL
Resolution
You may also need to work with the IT team in your company to allow the Salesforce package to access your Jira server instance through the Internet and fix the connectivity issue as you would require for the URL to be accessible to Salesforce cloud.