Create and Link Actions
On this page:
Create and link issues with predefined configuration
With Issue Matrix Cloud, you can set up actions that allow users to easily create and link new issues using predefined Project, Issue Type, and Link Type. You can configure the actions when creating an Issue Links matrix, and then access these actions from the Issue Matrix panel in the issue view screen.
To find the actions in the issue view screen, just look for the more menu (“…”) in the upper right corner of the Matrix panel. You'll see them listed there, as shown in (1) and (2) on the screenshot below.
Create and Link Actions configuration
To configure Create and Link Actions:
Go to Project settings or Project settings > Apps for team-managed projects.
From the left menu, choose Issue Matrix configuration.
If you are creating a new matrix, click the Add Matrix button on the Issue Matrices page and select the Issue Links type from the dropdown. If you want to configure actions for an existing Issue Links type matrix, click the pencil icon in its Actions column.
Navigate to Actions > Create and Link in the configuration.
Set up a create and link action by choosing:
Name - The action title that will be shown in the more menu (“…”) dropdown just above the Matrix panel.
Project - The project where the new issue will be added.
Issue Type - The type of the new issue.
Link Type - The type of the link between the currently viewed and the newly created issue.
Selecting Current Project in the Action configuration
When configuring a new Create and Link action, you have the option to add all new issues to the Current Project. The Current Project refers to the project of the currently open issue. However, if you have configured the Issue Matrix for two or more linked projects and you choose an issue type that is not available in all linked projects, a warning will be displayed next to the issue type in the action configuration (see the screenshot above).
The warning message will provide a list of projects where the chosen issue type is available and notify you that the action will only be available in those specific projects.
How to create and link new issues?
The Create and Link actions feature in the Issue Matrix panel makes it easier to create new issues. It automatically fills in the Project, Issue Type, and Linked Issues fields on the Create issue screen with information from the Issue Matrix configuration.
To create and link new issues using the Issue Matrix panel:
Open an issue in a project that has an Issue Links Matrix set up.
Click the more menu (“…”) in the top-right corner of the Issue Matrix panel.
Choose a preconfigured action from the dropdown menu.
The Create issue screen will appear with Project, Issue Type, and Linked Issues fields pre-filled with the values from the Matrix configuration.
Enter the required fields for the new issue.
Modify the pre-filled values for the Project, Issue Type, and Issue Link Type fields if needed.
Note that some projects may not display the Linked Issues field (which defines the link type) on the Create issue screen for the specified issue type. If this is the case, the new issue will still be created and linked to the current issue, but users will not be able to modify the preconfigured link type for the action.Add any other necessary information, then click Create to finish. If you want to create and link additional issues, select the Create another checkbox before clicking Create.
The new issue will be added to the project and linked to the current issue. If Create another is selected, all issues will be added to the project and linked to the current issue after the user creates their last issue.
How to fix problems in projects with a missing Linked Issues field on the Create issue screen?
Problem: When creating and linking a new issue, for some projects, the issue may be created but not linked. This can happen in projects that don't have the Linked Issues field (i.e., the field which defines the link type) present on their Create issue screen. If the Create another checkbox is selected, the created issues may all fail to link to the current issue.
Symptoms:
The Issue field doesn’t appear in the Create and Link screen when creating the new issue.
The new issue is created and added to the project but is not linked to the current issue.
The following warning message appears on the screen: “We encountered an error while trying to link issue 'X' to the current issue. Issue 'X' has been created but is not linked. Try linking the issue manually.” If the Create another checkbox is selected, the warning message will not be displayed for any of the issues that fail to link.
Possible causes:
Your Internet connection might be unstable or slow.
There might be a problem with the Jira Cloud site.
Solution:
Find the newly created issue in your project.
Open the issue that you want to link the new issue to.
Go to the more menu (…) > Link Issue.
Manually add the issue key of the new issue and select the link type.
Click Link to link the issues.
If the issue still doesn't link properly, contact Atlassian’s support.