Issues are not created
Problem
I have setup my Gaia Configuration with an issue file to import, but the issues are not created and the project is empty.Â
Causes
Several things could have occurred. Here are some :Â
Invalid XML issue file format | Make sure you export your file in the XML format available by JIRA. Make sure you do a CTRL+S directly in your browser.
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Invalid Issue Type Scheme | The selected issue type scheme for the project you just created does not match the issues in the file. For instance, you have Tasks in your xml files and Task are not present in the project issue type scheme. |
Invalid JIRA instance settings | The xml file exported depends on several settings from your JIRA instance: time and date settings, time tracking, language. Make sure they are valid and compatible with XML issue file. Trying to export from one instance and reimport to another one may cause several problems, which lead to refuse issue import. |
Unicode Transformation Format | Gaia for Jira app supports only UTF-8. Make sure your file has the appropriate code format. |
Using Special Characters | The XML specification defines "predefined entities" representing special characters, and requires that all XML processors honor them. These characters need to be escaped to obtain a well-formed document:
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Look at the logs
You may investigate the reasons by looking into the atlassian-jira.log file. Go to your JIRA installation directory (chances are that it is C:\Program Files\Atlassian\Application Data\JIRA\logs and look at the last lines. You may search for "ERROR" to try to find [ca.nuum.gaia] entries. You may have a clue of what went wrong in there.Â
Send us your log file and issue.xml file
We can always help you debug your case. Please report to the Logging page for instructions on how to generate detailed logs for us to debug. Then, you may zip and send us your logs, along with the ISSUE.XML file you have generated. You may also export your Gaia Configuration in a .package file (which will contain your Gaia Scheme Configuration as well). See the support email in the sidebar.