New macros do not appear upon installing Cloud app
Summary
Upon installing a Confluence Cloud app, new macros bundled with the app are not available in Confluence.
Symptoms include:
the new macros are not listed in the Confluence macro browser
the new macros do not appear via keyboard shortcuts ("{" for old editor, and "/" for new editor)Â in Confluence page editor
The macros may only become available after 24 hours, or in some cases, a few days.
Environment
Confluence Cloud
Latest version for Confluence Cloud of one of the following
Diagnostics Steps
Refreshing the web browser does not solve the problem.
Cause
There is a known issue in Confluence Cloud, reported at
This issue prevents macros of newly installed apps from appearing in Confluence due to a web caching problem.
Workaround
Apply ANY of the following workarounds
when viewing the Confluence page editor, "hard refresh" the web browser
this forces the web browser to clear web cache specific for the Confluence page editor
See the "How to Force Refresh a Single Page for All Browsers" section on this external article for specific instructions for your web browser type and operating system.
clear the entire web browser cache
this forces the web browser to clear web cache for all websites
See the "How to Clear Browser Cache..." sections on this external article.Â
work in incognito mode
this requires you to sign in to Atlassian Cloud
The new macros should appear in your Confluence editor after completing the workaround.