Skip to end of banner
Go to start of banner

WIP-How to stop a long running snapshot in Configuration Manager for Jira

Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 19 Next »

Problem Statement

While creating a snapshot of a project with several issues, if the process is interrupted and when an attempt to take another snapshot is made, the below error is thrown:

Error Message 

Job with name 'com.botronsoft.jira.rollout.snapshot' has already been scheduled.

Log Entries 

ERROR user1234 xxxxxxxxx xxxxxxxxxxx 10.0.1.1,10.0.1.2,10.0.1.3 /rest/configuration-manager/1.0/snapshots/progress/4 [c.b.j.r.impl.rest.AbstractResource] com.botronsoft.jira.rollout.jobs.JobAlreadyScheduledException: Job with name 'com.botronsoft.jira.rollout.snapshot' has already been scheduled
java.util.concurrent.ExecutionException: com.botronsoft.jira.rollout.jobs.JobAlreadyScheduledException: Job with name 'com.botronsoft.jira.rollout.snapshot' has already been scheduled

Environment

ApplicationJira
HostDatacenter

Cause

CMJ allows only one snapshot creation at a time. This means that before you attempt another one, you should wait for the current one to complete.

Solution

To create a new snapshot, here is the way:

  • When an operation is running in the background, wait for the previously started operation to be completed. You can monitor this in the CMJ's Audit log for a message that suggests the snapshot is created. Please refer to Audit Logging for more details.

To kill the process of snapshot creation, here is the way:

  • Rarely can the operation get stuck because of an unexpected issue with the platform. To kill the process anyway, the solution is to restart JIRA and create a new snapshot.
  • No labels