"Create Jira Issues" and "Associate" Buttons are visible to admins only

Summary

Under Salesforce Lightning Experience, the Create Jira Issues and Associate buttons are only visible to admins. 

Environment

  • Jira Cloud

  • Jira Server

Cause

The user's profile doesn't have the Apex Class access permission enabled for JCFS classes.

The user's profile doesn't have the Apex Class access permission enabled for JSFS classes.

Resolution

  1. Identify the users who aren't able to see the Create Jira Issues and Associate buttons.
    In Salesforce, go to Setup > Users > Profiles > click on the users' profile.

  2. Look for and edit Enabled Apex Class Access.

  3. Make sure all JCFS classes have been added to the Enabled Apex Classes column.

     

  1. Identify the users who aren't able to see the Create Jira Issues and Associate buttons.
    In Salesforce, go to Setup > Users > Profiles > click on the users' profile.

  2. Look for and edit Enabled Apex Class Access.

  3. Make sure all JSFS classes have been added to the Enabled Apex Classes column.