Skip to end of banner
Go to start of banner

How to stop a long taking snapshot\deployment in Configuration Manager for Jira

Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 2 Next »

Problem Statement

If while creating a snapshot of a project with several issues, if the process is interrupted and then when attempt to take another snapshot the following error is thrown 

Error Message 

Job with name 'com.botronsoft.jira.rollout.snapshot' has already been scheduled.

Log Entries 

ERROR user1 445x98019x1 116nnw6 10.251.86.81,10.80.80.8,10.53.49.80 /rest/configuration-manager/1.0/snapshots/progress/4 [c.b.j.r.impl.rest.AbstractResource] com.botronsoft.jira.rollout.jobs.JobAlreadyScheduledException: Job with name 'com.botronsoft.jira.rollout.snapshot' has already been scheduled
java.util.concurrent.ExecutionException: com.botronsoft.jira.rollout.jobs.JobAlreadyScheduledException: Job with name 'com.botronsoft.jira.rollout.snapshot' has already been scheduled

Environment

ApplicationJira
VersionServer

Cause

CMJ allows only one snapshot creation operation at a time. This means that before you attempt another one, you must wait for the currently running one to complete.

Solution

  1. To kill an ongoing process of snapshot creation, below are the two options.
    • As the operation is still running in the background, wait for the previously started operation to complete. You can monitor CMJ's Audit Log for a message that suggests that the snapshot is created.
    • Rarely, the operation can get stuck because of a platform issue. In this case, the solution is to restart JIRA and create a new snapshot
  • No labels