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No file locks are available on the NFS file system. This problem will occur if your Jira is running runs on an NFS file system - this applies mainly to Jira Data Center.

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  • after performing a "Create Snapshot" operation,

  • after starting the "Restore" process,

  • after updating the application to a newer version.

Diagnosis

Verify if the following entry appears in the logs:

Code Block
============================================================================================================
NO LOCKS AVAILABLE, this error is usually caused by the NFS daemons not running or malfunctioning.
Try to restart and verify functionality of all NFS related daemons on your system, most importantly lockd.

You can also make sure ensure this is the case , by manually creating a lock on a file in a directory used by the plugin, e.g. /shared-data/sharedhome/export/softwareplant/bigpicture. As a result of such action, the same error should appear as in our application logs i.e., "No locks available".

Solution

Restart and verify the functionality of all NFS-related daemons on your system, most importantly lockd. See the following page for further reference: http://osr507doc.sco.com/en/NetAdminG/nfsC.daemons.html

...

  • after performing a "Create Snapshot" operation,

  • after starting the "Restore" process,

  • after updating the application to a newer version.

Diagnosis

Verify if the following entry appears in the logs:

...


For Unix/Unix-like systems, use the command: 'chown <user that jira is run on the behalf of> <directoryPath>'
e.g. 'chown jira jira-data'

Info

In case If you are experiencing more complicated issues or having problems following the instructions, please contact our helpful support using the customer portal. Our team will be more than welcome happy to assist.