Symptoms:
Deploying a snapshot results in one of the following errors:
- Unknown: This site is currently undergoing maintenance. We apologize for the inconvenience. Proxy error.
- Unknown: 504 Gateway Timeout
- Request terminated: The current operation was terminated unexpectedly.
Often these errors come with no CMJ related error logs reported.
Cause:
These kind of errors usually indicate a client side or a network issue, i.e. something is terminating the request before it reaches the server. Firewall, proxy and browser timeouts are a common reason for such errors.
Note: On the initial step of the deployment wizard CMJ performs a long running HTTP request that can take up to several minutes while the target's configuration is being analyzed and compared to the snapshot.
Resolution:
The following actions could aid in the problem resolution:
- Generating and analyzing a .HAR file of the network traffic from the time of the error could give an evidence of request that timeouts
- If there is a proxy/firewall between the client machine and the destination server, increasing the timeout will keep longer running operations from terminating
- Working together with a network administrator can help analyze the network infrastructure