New macros do not appear upon installing Cloud app
Summary
Upon installing a Confluence Cloud app, new macros bundled with the app are not available in Confluence. Symptoms include:
The new macros are not listed in the Confluence macro browser.
The new macros do not appear via keyboard shortcuts ("{" for old editor, and "/" for new editor)Â in Confluence page editor.
The macros may only become available after 24 hours, or in some cases, a few days.
Environment
Confluence Cloud
Latest version of Composition Tabs for Confluence, Linking for Confluence, Redirection for Confluence, or Visibility for Confluence for Confluence Cloud
Diagnostics Steps
Refreshing the web browser does not solve the problem.
Cause
There is a known issue in Confluence Cloud, reported at https://jira.atlassian.com/browse/CONFCLOUD-58280. It prevents macros of newly installed apps from appearing in Confluence due to a web caching problem.
Workaround
Apply ANY of the following workarounds:
When viewing the Confluence page editor, "hard refresh" the web browser. This will force the web browser to clear the web cache specific to the Confluence page editor.
See the "How to Force Refresh a Single Page for All Browsers" section on this article for specific instructions for your web browser type and operating system.
Clear the entire web browser cache. This will force the web browser to clear the web cache for all websites.
See the "How to Clear Browser Cache..." sections in this article.Â
Work in incognito mode. This will require you to sign in to Atlassian Cloud.
See this article for specific instructions on how to activate the mode.
The new macros should appear in your Confluence editor from now on.
Multiple options can be selected.