How to troubleshoot 'Failed to push to Jira!' error message

Summary

Failed to push to Jira error message prompts when pushing updates manually from Salesforce to Jira. 

Environment

  • Jira Cloud/Server

  • Any

Diagnostics Steps

Web requests can provide the full error message for further troubleshooting.

Causes

Failed to push to Jira error message can be caused by various issues. Below are the possible error messages you might find in the browser web requests:

Jira Status field is a Read-Only field. Therefore, only outbound sync (Jira > Salesforce) is supported.

As the error suggests, the custom field with ID '10112' is not on the appropriate screen. Specifically, the custom field is not on the Edit Issue screen. 

The connector uses the mapped fields on the Jira Edit Issue screen to push updates from Salesforce to Jira. 

This might be due to mapping incompatible field types. For example, having Jira 'Select List (single choice)' field type mapped with Salesforce 'Picklist(Multi)' field type. 

The mapped fields are compatible with one another. However, the value 'Child 1' is unavailable in Jira. 

Resolution

  1. Go to Jira, Apps > Salesforce > Bindings > Mapping > Mappings

  2. Locate Status field mapping 

  3. Make the sync direction pointing to Salesforce only (Outbound sync) as shown as the picture below:

 

The error message is not listed here? Please contact Technical Support for further assistance.