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Troubleshoot the CLI client impacted by the GDPR - Cloud Platform changes

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Problem statement

The CLI client is seeing a remote error while accessing the cloud instance, as part of the platform changes related to GDPR.

Error message 

Remote error: User is not authorized to perform the request. Response code: 401.

Environment

ApplicationConfluence, JIRA
Version Cloud
App version8.4.0

Cause

The error is caused due to the recent changes in the authentication parameters for the Cloud instance, as recommended by the GDPR guidelines issued by Atlassian. 

Solution

CLI users must upgrade their CLI client to the latest version available to rollout GDPR platform changes. The Username and Password parameters accept only user email address and token respectively. 

To generate the token:

  1. Click your profile avatar on the bottom left corner.

  2. Navigate to Profile > Manage your account > Security.

  3. Under API token, click Create and manage API tokens (If you see a blank screen, refresh the page Or open this in another browser).

  4. Click Create an API token. A token is created that needs to be copied and kept securely.

Perform the following to avoid the error:

  1. Download CLI client 8.5.0 from this location.

  2. Enter the following:

    • Username - User email address

    • Password - Token

Example for the Linux environment: 

java -jar /opt/atlassian/cli/atlassian-cli-8.5.0/lib/jira-cli-8.5.0.jar --server https://your-site.atlassian.net --user "john@example.com" --token rg97a5s4agsjsd732 "$@"


Example for the Windows environment:

java -jar D:\CLI\atlassian-cli-8.5.0-distribution\atlassian-cli-8.5.0\lib\jira-cli-8.5.0.jar --server https://your-site.atlassian.net --user "john@example.com" --password "jLBdxOCRPvsiOdu0XiBcA088" %*


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