"You do not have a valid license." error when interacting with the status panel in the Page Approval for Confluence app

Summary

The “You do not have a valid license. Please contact your space administrator.“ error is displayed when you:

  1. Attempt to make a new request by clicking the Request Approval button

     

  2. Viewing a page status panel that has been approved, rejected, or in pending approval status

Environment

  • Confluence Cloud

Cause

The product license for Page Approval for Confluence Cloud has expired or is invalid. This error may also be caused by an API key used to communicate, which has been rotated recently.

Resolution

If the issue is caused by the rotated API key, removing the error requires triggering the subscription again.

Please proceed to:

  1. Go to Confluence > Manage Apps > Page Approval Settings > click on Subscribe

  2. Go to the concerning Space > Page Approval settings (on top left) > click on Subscribe

If all the above fails, please request the space administrator to renew the product license, or if the issue persists, reach out to our support team.