Unable to log time on mandatory issue when using the Reports and Timesheets for Jira app

Unable to log time on mandatory issue when using the Reports and Timesheets for Jira app

This article explains why the user is unable to log time on mandatory issues and sees an ‘Unknown error’ message.

Jira Environment
Jira Cloud

Problem

Users are unable to log work on a specific issue that has been added as mandatory on their timesheet. When attempting to log time, the system returns an “Unknown error” message for the affected issue.

The problem is isolated to a single Jira issue and does not impact other issues on the same timesheet.

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Root cause

This behavior is caused by a performance optimization introduced by Atlassian on the Jira Cloud.
When an issue contains a very large number of worklogs, Jira might fail to load or process worklog-related operations correctly, resulting in generic errors such as “Unknown error”.

This is a known Jira Cloud limitation and is not caused by the Reports and Timesheets plugin.

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Solution

Since this is a Jira Cloud limitation, the resolution is based on Atlassian’s recommended workaround.

  • Option 1: Delete extra attachments with Jira automation (Data Center or Cloud)

  • Option 2: Delete extra attachments with API

For more details, refer to https://confluence.atlassian.com/enterprise/issues-with-too-many-work-logs-1402420958.html#:~:text=Still%20need%20help?,affected%20issues%20with%20SQL%20query