Cloud Migration Resources
Planning a Jira Cloud migration? These resources can help you get started:
→ Connector for Salesforce & Jira Cloud features – Review Cloud features and understand key differences between DC and Cloud.
→ Migration support from Appfire – Learn how we can help you migrate smoothly.
"Salesforce security settings blocked the connection" error
Summary
When trying to authorize the connection after logging into Salesforce, rather than continuing to the configuration wizard, a message stating Salesforce security settings blocked the connection displays.
The message also provides links to this document page and to the Support portal.
Environment
JIRA Cloud
Diagnostics Steps
Check the URL shown in the browser and whether it contains this string -
OAUTH_APP_ACCESS_DENIED
If you do not see theOAUTH_APPstring, read Page cannot be found when I try to re-authorize connection with Salesforce.In Salesforce, navigate to Apps > Connected Apps > Manage Connected Apps to check the connector policies.
Cause
Either the Salesforce user that is used for authorization has not been approved by the Salesforce admin, or the connector is not set to All users may self-authorize.
Workaround
Not applicable.
Resolution
Do either of the following:
Make sure that the Salesforce user being used for authorization is approved by the Salesforce admin. More details are available on this Salesforce page.
Or, edit the policies to change the Permitted Users option to "All users may self-authorize"