Review and Create screen in Salesforce is not displaying the fields configured in Jira
Summary
When creating a Jira Issue from the Salesforce Lightning Component or the Visualforce Page, there is a button to allow you reviewing the information before creating the ticket.
However, even after setting up the fields in the appropriate screen in Jira, those fields are not rendered into the Salesforce component.
Environment
Jira Cloud
Jira Data Center
Diagnostics Steps
The field can be found on the screen by performing the following:
Click Create to open the Create Issue screen on your Jira site.
Click the Menu icon
on the top right corner of the Create Issue screen.
Select Find your field and type the field name. After finding the field, you will see the following error:
Cause
The administrator has set up a custom field, but the affected project and issue type are not linked to it.
Workaround
Not applicable.
Resolution
In order to allow the users to interact with this field on the screen in Jira (the equivalent of the Salesforce's Review and Create screen), the administrator must add the missing project and issue type to the field context:
Go to your Jira site.
Click the Cog icon
and select Issues.
In the left tab, search for the Fields section > select Custom fields.
Search for your field > click the Menu icon
> Contexts and default value.
Click Edit Context.
Select the affected project and issue type.
Select Modify to save changes.