Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

When deploying project (or multiple projects) that doesn't contain any Jira Agile/Software objects referenced in its configuration then CMJ reports Jira Agile as required plugin to continue the deployment. The source instance has Jira Agile installed while the target instance has no Jira Agile installed.

Cause:

The most common reason for CMJ to report a plugin as required during a project deployment is a custom field provided by that plugin referenced by some of the project configuration or with a value in some of the project's issues.

There are two custom fields provided by Jira Agile/Software that CMJ will treat differently .if Jira Software is installed on the source instance:

Epic Color

To analyze whether there are issues with a value for that custom field, CMJ is using a JQL query similar to "project = XXX and cf[YYYYY] is not empty". This works as expected for all fields (i.e. returns all issues that have no value for the specified custom field) except for the "Epic Color" field.As the only exception, "Epic Color" (com.pyxis.greenhopper.jira:gh-epic-color) custom field has more special treatment when used in that filtering statement and the result from the JQL query (even if executed in the issue navigator) is all issues that are allowed to have a field will always be included in the snapshot if the snapshot contains issues or the option for including fields with values in issues is selected. Jira will always treat that all issues have value for "Epic Color" no matter if a value is set or not.

For example, "project = XXX and cf[<ID of 'Epic Color'>] is not empty" will result in all issues in project XXX.

Note: This will also influence CMJ's Power Admin results for issues that use "Epic Color".

Having all that said, "Epic Color" custom field is always included in the snapshot when the source instance has Jira Agile/Software installed and thus CMJ requires Jira Agile on the target instance to deploy the configuration.

Rank

CMJ will always create a ranking container based on the Jira Software's "Rank" custom field even if only Service Desk projects are exported. This might be required, for example, when some of the exported project's issues are part of a board with filter including an explicit clause for the exported project. Having the "Rank" custom field referenced in the ranking container inside the snapshot, will require Jira Agile on the target instance to deploy the configuration.

Rank

This field is global and will be included in the snapshot no matter what projects are exported. The field will be used by CMJ to maintain the ranking of the issues if they are part of a board.

Resolution:

To continue the deployment you will need to install Jira Software on the target instance. It is enough to have Jira Software only during the deployment. You can also use a trial license for Jira Software and uninstall it after the deployment if it is not needed on the target instance.