...
...
...
...
...
...
Problem statement
The CLI client is showing a remote error while accessing the cloud instance, as part of the platform changes related to GDPR.
Error message
Code Block | ||||
---|---|---|---|---|
| ||||
Remote error: User is not authorized to perform the request. Response code: 401. |
...
Code Block | ||||
---|---|---|---|---|
| ||||
Remote error: Unknown error occurred on the server. Response code: 501. |
Environment
Application | Confluence, JIRAJira |
---|---|
Version | Cloud |
Cause
Panel | ||
---|---|---|
| ||
The error is caused due to the recent changes in the authentication parameters for the Cloud instance, as recommended by the GDPR guidelines. |
Problem determination
- For some Confluence Cloud API removals, you may see the following if you do not have an updated CLI client:
- Remote error: Action disallowed. Response code: 403.
- Remote error: Unknown error occurred on the server. Response code: 501.
- If you are NOT using the email address and API token for your user credentials for accessing Cloud sites (see Authentication), you will likely receive: Remote error: User is not authorized to perform the request. Response code: 401.
- Even when using an API token, we have cases of 401 errors caused by older API tokens. Revoke the existing token and generate a new token. Then execute the CLI command.
Solution
CLI users must upgrade their CLI client to the latest version available to rollout GDPR platform changes. The Username and Password parameters accept only user email address and token respectively.
...
Download the latest version of CLI distribution (Client) from this location.
Enter the following:
Username - User email address
Password - Token
...