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The Power Admin page shows the same Rank custom field as locked.
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Environment
Component | Server/Data center |
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Application | Power Admin |
Database Type | N/A |
Cause
The KB article https://confluence.atlassian.com/jirakb/unlock-a-locked-jira-software-custom-field-779158866.html used to ‘unlock’ the fields suggests changing the managed
field in the managedconfigurationitem
table from ‘true’ to ‘false’ for the field that needs to be unlocked. However, some applications (including Power Admin) still treat the field as locked since they use the actual access_level
specified in another field in the same table.
Solution
Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
To unlock the field to change with Power Admin, follow the
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steps
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listed in the KB article (https://confluence.atlassian.com/jirakb/unlock-a-locked-jira-software-custom-field-779158866.html)
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Also, change the value of the
access_level
field to ‘ADMIN’
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.
UPDATE managedconfigurationitem set ACCESS_LEVEL='ADMIN' where item_id in ('customfieldID');
Make the required changes to the fields.
Lock the fields that were unlocked by setting the managed column to true. For example, the below will lock the Ranking custom field.
Code Block UPDATE managedconfigurationitem set managed='true' where item_id in (<customfield_id>); UPDATE managedconfigurationitem set ACCESS_LEVEL='
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LOCKED' where item_id in ('customfieldID');
Info |
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These fields will be locked again on startup by automated tasks within plugins. |