Symptoms
Error message
or this exception:
Code Block | ||
---|---|---|
| ||
java.lang.IllegalStateException: Unable to find model version in file /cust/app/jira/temp/activeobjects.xml860047787519460231snapshot.tmp.xml at com.botronsoft.jira.rollout.model.util.EcoreCustomUtil.getModelVersion(EcoreCustomUtil.java:92) at com.botronsoft.jira.rollout.model.migration.impl.ModelMigrationServiceImpl.migrate(ModelMigrationServiceImpl.java:138) at com.botronsoft.jira.rollout.impl.ModelLoader.loadModel(ModelLoader.java:50) at com.botronsoft.jira.rollout.impl.JiraConfigurationResourceServiceImpl.loadModel(JiraConfigurationResourceServiceImpl.java:36) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) |
Cause
Failures in EcoreCustomUtil.getModelVersion are caused by uploads of a non-snapshot file or a corrupted one (via incorrect manual modification or due to a problematic transfer/download).
Resolution
Make sure you're uploading a valid snapshot file that is not manually edited or in any other way corrupted (copying snapshots between VMs or downloading very large files is a common cause for this).
- Try to download the snapshot file again. If the file is with a bigger size you could choose to exclude the attachments as described in this wiki page: Moving attachments.
- If the problem persists validate the integrity of the ZIP file (the actual steps depends on the operating system of the client machine).
- Other workarounds:
- Downloading the snapshot directly from the source Jira server, they are located in %JIRA_HOME%\export\snapshots.
- Also, it's possible to use application links and deploy the snapshot directly from the source instance, this way CMJ handles the transfer.
...
If none of the tips above help, contact our support team at Botron's Support Portal. Attaching a support zip from the target instance and the snapshot will help our support team a lot.