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This article explains how to rename an unlocked custom field using the Power Admin app.

\uD83D\uDCD8 Problem Statement

Even though you unlocked the “Ranking”(used as an example) custom field from the database you will not be able to rename the field in Power Admin as it is still shown as ‘locked’.

Error screenshots 

The custom field page is showing that the Rank custom field is unlocked from the database.

...

The Power Admin page is showing the same Rank custom field as locked.

...

Environment

Component

Server

Application

Power Admin

Database Type

N/A

Cause

The KB article used to ‘unlock’ the fields suggests changing the managed field in the managedconfigurationitem table from ‘true’ to ‘false’ for the field that you want to unlock. However, some applications (including Power Admin) still treat the field as locked since they use the actual access_level specified in another field in the same table.

Solution

To unlock the field for changing with Power Admin you can follow the same steps specified in the KB article (https://confluence.atlassian.com/jirakb/unlock-a-locked-jira-software-custom-field-779158866.html ) but also should change the value of the access_level field to ‘ADMIN’.

Example:
UPDATE managedconfigurationitem set ACCESS_LEVEL='ADMIN' where item_id in ('customfieldID');

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